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See also main SDK page.

AEE - Introduction

In this example we will show how to create custom administration page.
what will be shown in the example

1. how to create custom administration page
2. how to register custom administration page to Polarion

AEE - Java APl Workspace preparation
See section Workspace preparation

AEE - Creating project plugin

The best way is to import provided example, which contains all dependencies you need for custom plugin creation

AEE - Import of the example

Info: You must ensure that your plugin is compiled against your Polarion version. This example contains precompiled jar plugin. You can remove it
before you start developing your plugin based on this example. The Eclipse ensure that new jar plugin will be created against your source code and
Polarion version.

To import this example to workspace, do these steps:

Select File > Import...
In the dialog that appears, select Existing Project into Workspace in General section and press Next button.
. By pressing Browse.. button, select the directory of examples (mostly in C: PolarionpolarionSDKexamples</tt>). Submit it.

e N

Select com.polarion.example.administration and press Finish.

AEE - Deployment to Installed Polarion

See section Deployment to Installed Polarion

AEE - Execution from Workspace

See section Execution from Workspace

AEE - Configuration
Custom administration pages are registered via hivemodule.xml to contribution with id com.polarion.xray.webui

.administrationPageExtenders.

Extender attributes: id (required), name, iconUrl, pageUrl, parentNodeld, parentNodeName, parentNodeIconUrl,

projectScope (Boolean), projectGroupScope (Boolean), repositoryScope (Boolean)

§<?xm1 version="1.0" encoding="UTF-8"?>

<module id="com.polarion.example.administration" version="1.0.0">
<contribution configuration-id="com.polarion.xray.webui.administrationPageExtenders">
: <extender id="administrationExample"

é parentNodeId="administrationExampleFolder"

: name="Page" parentNodeName="Example"
:parentNodeIconUrl:"/polarion/icons/default/topicIcons/Toolsil57fwrench.png"
: iconUrl="/polarion/icons/default/topicIconsSmall/Tools_158-wrench-2.png"
gpageUr1="/polarlon/admlnlstrationExample/administratlon.jsp?scope=$scope$"
. projectScope="true" projectGroupScope="true" repositoryScope="true"/>
</contribution>

</module>

Requirements

Development Environments

e Eclipse IDE for Enterprise Java Developers or any other Eclipse IDE with The Eclipse Plug-in Development
Environment. (Go to Help > Install New Software.. > Install Eclipse Plug-in Development Environment >
Restart Eclipse)

e Eclipse Temurin™ 17 (LTS) by Adoptium for building and running your code.

Workspace Preparation

To start developing a Polarion Java API plug-in, you first need to perform following steps:


https://www.eclipse.org/downloads/
https://adoptium.net/temurin/releases/

1. Start Eclipse, then select Window > Preferences...

2. In the dialog that appears, select Plug-In Development > Target Platform.

3. Click the Add button on the right.

4. Keep the Nothing: Start with an empty target definition option selected and click Next.
S NewTa n O
Target Definition @

Create a new target definition. @
N

Initialize the target definition with:

© Nothing: Start with an empty target definition

() Default: Default target for the running platform

() Current Target: Copy settings from the current target platform

(O Template: Base RCP (Binary Only)

@' < Back Finish Cancel

Figure WP-1: Starting with an Empty Target Definition
5. Enter a Name and click Add.
6. Select Directory and click Next.

7. Click Browse and select the C:\Polarion\polarion folder (Windows) or /opt/polarion/polarion (Linux).

e level above the plugins folder.)
8. Click Next.

| & Add Content O

: Preview Contents

The plug-ins found in the container are visible below

Plug-ins:

<= com.polarion.synchronizer.proxy.polarion (3

<= com.polarien.synchronizer.proxy.reqif (3

<= com.polarien.synchronizer.ui
= com.polarion.synchronizer (2.
= com.polarion.usdp.persistence |
<= com.siemens.plm.biteels.analytics |
<= com.siemens.polarion.ct.collectors.git (3.2

<= com siemens.polarion.eclipse.configurator |

= com siemens.polarion.integration.ci (3

R SRS - . YRR I .. T 1. B

@' < Back Mext > Cancel

Figure WP-2: Currently Installed Polarion Plug-ins
9. A list of currently installed Polarion plug-ins appears.

Click Finish.

(On



& Edit Targ tion O
Target Content r
Edit the name, description, and plug-ins contained in a target. @
hd

MName: Polarion

Locations Content Environment Arguments Implicit Dependencies

The following list of locations will be used to collect plug-ins for this target definition.

(= C\Polarion\polarion 295 plug-ins available Add...
Edit...
Remove
Update
Refresh

Expand All

] Show locatien content

Figure WP-3: Confirm the Selected Path
10. The selected path and the number of discovered plug-ins available appear. Confirm that the path is
correct and click Finish.{WP 4.png|description=Figure WP-4: Select the Target Platform}
11. Check the box beside the newly added path and click Apply.

Deployment to Installed Polarion
You can deploy a plugin to Polarion in two ways. First you can export a project as Deployable Plugins and
Fragments. The second way is described in the following section Execution from Workspace. To export the

plug-in, perform these steps:

1. Select File > Export...

2. In the dialog that appears, select Deployable Plugins and Fragments in Plug-in Development section and
click the Next button.

3. Mark your project (e.g. for Servlet example it will be com.polarion.example.servlet), and as the
destination directory specify the polarion folder of your Polarion installation directory (usually in C:
\Polarion\polarion)

4. At the Options card be sure, that Package plug-ins as individual JAR archives is unchecked. Click Finish

5. Because this is a new polarion plug-in extension, you have to restart your Polarion server.

NOTE: Servlets loaded by Polarion are cached in: [Polarion Home]\data\workspace\.config. If this folder is
not deleted before deploying a servlet extension (plugin) and restarting Polarion, then either the servlets

will not be properly loaded, or the old ones will be loaded.

Execution from Workspace

The second way to deploy the plug-in to Polarion is to launch Polarion directly from your Eclipse workspace.
This method has the added advantage of debugging the code directly in Eclipse.

1. Select Run > Open Debug Configurations..
2. Create a new Eclipse application (double click on Eclipse Application)
3. You should set:



& Debug Configurations O X

Create, manage, and run configurations

Create a configuration to launch an Eclipse application in debug mode.

[} IE’ <0 ® | =) '\l_]) T Mame: Polarion Server
type filter text : Main | ()= Argumentsl = Plug-ins| Configuration| Tracingl - -} Environment| S| Common| [P| Prototype
w & Eclipse Application Waorkspace Data
= New_configuration Location: C:\Polarion‘\data\workspace
@ Gradle Test
Java Applet [ Clear: workspace log enly Workspace.. File Systerm... Variables...
Java Application Ask for confirmation before clearing Configure defaults...
Ju JUnit
3¢ JUnit Plug-in Test Program to Run
@ Launch Group Run a product: 4 org.eclipse.platform.ide
4 05Gi Framework
E. Remote Java Application © Run an application:  com.polarion.core.boot.app 7

Java Runtime Environment

Java executable: D Default (javaw) Djava
() Execution envirenment:  CDC-1.0/Foundation-1.0 (jre-17.0.8) Environments...
© Runtime JRE: jre-17.0.6 ~ Installed JREs...

Bootstrap entries:

. . Show Command Line Revert Apply
Filter matched 10 of 10 items

®

Figure EXEC-1: Debug - Main page
e Name to Polarion Server
e Workspace Data Location to C:\Polarion\data\workspace (assuming that your Polarion is installed in
C:\Polarion\) .
e Run an application to com.polarion.core.boot.app in the Program to Run section.
4. Finally set your Runtime JRE. On the second, "Arguments" tab, set the following arguments:

In the Program Arguments section:

Windows:

-0s win32 -ws win32 -arch x86 -appld polarion.server

}os linux -ws gtk -arch x86_64 -appld polarion.server

In the VM Arguments section:

Windows:

}Xmslg -Xmx1lg

~Dcom.polarion.home=C:\Polarion\polarion

}XX:+UseBiasedLocking -XX:BiasedLockingStartupDelay=0

‘--add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.lang.annotation=ALL-
‘UNNAMED

‘--add-opens=java.base/java.lang.invoke=ALL-UNNAMED --add-opens=java.base/java.lang.module=ALL-UNNAMED --add-
éopens=java.base/java.lang.ref=ALL—UNNAMED

---add-opens=java.base/java.lang.reflect=ALL-UNNAMED --add-opens=java.base/java.math=ALL-UNNAMED --add-opens=java.base/java.net=ALL-
‘UNNAMED

‘--add-opens=java.base/java.net.spi=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/java.nio.channels=ALL
‘UNNAMED

‘--add-opens=java.base/java.nio.channels.spi=ALL-UNNAMED --add-opens=java.base/java.nio.charset=ALL-UNNAMED --add-
éopens:java.base/java.nio.charset.spi:ALL—UNNAMED

‘--add-opens=java.base/java.nio.file=ALL-UNNAMED --add-opens=java.base/java.nio.file.attribute=ALL-UNNAMED --add-
éopens=java.base/java.nio.file.spi=ALL—UNNAMED

--add-opens=java.base/java.security=ALL-UNNAMED --add-opens=java.base/java.security.cert=ALL-UNNAMED --add-
fopens:java.base/java.security.interfaces:ALLfUNNAMED

-add-opens=java.base/java.security.spec=ALL-UNNAMED --add-opens=java.base/java.text=ALL-UNNAMED --add-
‘opens=java.base/java.text.spi=ALL-UNNAMED

‘--add-opens=java.base/java.time=ALL-UNNAMED --add-opens=java.base/java.time.chrono=ALL-UNNAMED --add-
éopens:java.base/java.time.format:ALL—UNNAMED

--add-opens=java.base/java.time.temporal=ALL-UNNAMED --add-opens=java.base/java.time.zone=ALL-UNNAMED --add-
‘opens=java.base/java.util=ALL-UNNAMED




--add-opens=java.base/java.util.concurrent=ALL-UNNAMED --add-opens=java.base/java.util.concurrent.atomic=ALL-UNNAMED --add-
‘opens=java.base/java.util.concurrent.locks=ALL-UNNAMED

‘--add-opens=java.base/java.util.function=ALL-UNNAMED --add-opens=java.base/java.util.jar=ALL-UNNAMED --add-
éopens=java.base/java.util.regex=ALL—UNNAMED

‘--add-opens=java.base/java.util.spi=ALL-UNNAMED --add-opens=java.base/java.util.stream=ALL-UNNAMED --add-
‘opens=java.base/java.util.zip=ALL-UNNAMED

---add-opens=java.base/sun.nio.fs=ALL-UNNAMED --add-opens=java.base/sun.security.ssl=ALL-UNNAMED --add-
éopens=java.datatransfer/java.awt‘datatransfer=ALLfUNNAMED

i-—add-opens=java.desktop/java.applet=ALL-UNNAMED --add-opens=java.desktop/java.awt=ALL-UNNAMED --add-
éopens=java.desktop/java.awt.color=ALL—UNNAMED

:--add-opens=java.desktop/java.awt.desktop=ALL-UNNAMED --add-opens=java.desktop/java.awt.dnd=ALL-UNNAMED --add-
gopens:java.desktop/java.awt.dnd.peer:ALL—UNNAMED

‘--add-opens=java.desktop/java.awt.event=ALL-UNNAMED --add-opens=java.desktop/java.awt.font=ALL-UNNAMED --add-
éopens=java.desktop/java.awt.geom=ALL—UNNAMED

---add-opens=java.desktop/java.awt.im=ALL-UNNAMED --add-opens=java.desktop/java.awt.im.spi=ALL-UNNAMED --add-
éopens:java.desktop/java.awt.image:ALLfUNNAMED

i--add-opens=java.desktop/java.awt.image.renderable=ALL-UNNAMED --add-opens=java.desktop/java.awt.peer=ALL-UNNAMED --add-
éopens=java.desktop/java.awt.print=ALL—UNNAMED

‘--add-opens=java.desktop/java.beans=ALL-UNNAMED --add-opens=java.desktop/java.beans.beancontext=ALL-UNNAMED --add-
fopens:java.desktop/javax.swing:ALL—UNNAMED

‘--add-opens=java.desktop/javax.swing.border=ALL-UNNAMED --add-opens=java.desktop/javax.swing.text=ALL-UNNAMED --add-
éopens=java.desktop/javax.swing.teXCAhtml=ALL—UNNAMED

---add-opens=java.desktop/sun.awt=ALL-UNNAMED --add-opens=java.desktop/sun.font=ALL-UNNAMED --add-opens=java.desktop/sun.java2d=ALL-
‘UNNAMED

‘--add-opens=java.instrument/java.lang.instrument=ALL-UNNAMED --add-opens=java.logging/java.util.logging=ALL-UNNAMED --add-
éopens=java.management/java.lang.management=ALL—UNNAMED

‘--add-opens=java.prefs/java.util.prefs=ALL-UNNAMED --add-opens=java.rmi/java.rmi=ALL-UNNAMED --add-opens=java.rmi/java.rmi.dgc=ALL-
‘UNNAMED :
~--add-opens=java.rmi/java.rmi.registry=ALL-UNNAMED --add-opens=java.rmi/java.rmi.server=ALL-UNNAMED --add-opens=java.sql/java.sql=ALL-
‘UNNAMED :
-add-opens=java.xml/com.sun.org.apache.xerces.internal.dom=ALL-UNNAMED --add-
‘opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED
‘-—add-opens=java.xml/com.sun.org.apache.xerces.internal.parsers=ALL-UNNAMED --add-
gopens:java.xml/com.sun.org.apache.xerces.internal.utll:ALL—UNNAMED

=¥Xmslg -Xmxlg

‘~-Dcom.polarion.home=/opt/polarion/polarion -Dcom.polarion.propertyFile=/opt/polarion/etc/polarion.properties

}XX:+UseBiasedLocking -XX:BiasedLockingStartupDelay=0 :
-—add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.lang.annotation=ALL-
‘UNNAMED :
--add-opens=java.base/java.lang.invoke=ALL-UNNAMED --add-opens=java.base/java.lang.module=ALL-UNNAMED --add-
éopens=java.base/java.lang.ref=ALL—UNNAMED

‘-—add-opens=java.base/java.lang.reflect=ALL-UNNAMED --add-opens=java.base/java.math=ALL-UNNAMED --add-opens=java.base/java.net=ALL-
‘UNNAMED :
:-—add-opens=java.base/java.net.spi=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/java.nio.channels=ALL-
‘UNNAMED :
-add-opens=java.base/java.nio.channels.spi=ALL-UNNAMED --add-opens=java.base/java.nio.charset=ALL-UNNAMED --add-
‘opens=java.base/java.nio.charset.spi=ALL-UNNAMED

i--—add-opens=java.base/java.nio.file=ALL-UNNAMED --add-opens=java.base/java.nio.file.attribute=ALL-UNNAMED --add-
éopens=java.base/java.nio.file‘spi=ALL—UNNAMED

i--add-opens=java.base/java.security=ALL-UNNAMED --add-opens=java.base/java.security.cert=ALL-UNNAMED --add-
éopens:java.base/java.security.interfaces:ALL—UNNAMED

‘--add-opens=java.base/java.security.spec=ALL-UNNAMED --add-opens=java.base/java.text=ALL-UNNAMED --add-
éopens=java.base/java.text.spi=ALL—UNNAMED

---add-opens=java.base/java.time=ALL-UNNAMED --add-opens=java.base/java.time.chrono=ALL-UNNAMED --add-
‘opens=java.base/java.time.format=ALL-UNNAMED

i-—add-opens=java.base/java.time.temporal=ALL-UNNAMED --add-opens=java.base/java.time.zone=ALL-UNNAMED --add-
éopens=java.base/java.util=ALL—UNNAMED

‘--add-opens=java.base/java.util.concurrent=ALL-UNNAMED --add-opens=java.base/java.util.concurrent.atomic=ALL-UNNAMED --add-
fopens:java.base/java.util.concurrent.locks:ALL—UNNAMED

-add-opens=java.base/java.util. function=ALL-UNNAMED --add-opens=java.base/java.util.jar=ALL-UNNAMED --add-
‘opens=java.base/java.util.regex=ALL-UNNAMED

--add-opens=java.base/java.util.spi=ALL-UNNAMED --add-opens=java.base/java.util.stream=ALL-UNNAMED --add-
éopens:java.base/java.util.zip:ALLfUNNAMED

‘--add-opens=java.base/sun.nio.fs=ALL-UNNAMED --add-opens=java.base/sun.security.ssl=ALL-UNNAMED --add-
‘opens=java.datatransfer/java.awt.datatransfer=ALL-UNNAMED

‘--add-opens=java.desktop/java.applet=ALL-UNNAMED --add-opens=java.desktop/java.awt=ALL-UNNAMED --add-
éopens:java.desktop/java.awt.color:ALL—UNNAMED

-—add-opens=java.desktop/java.awt.desktop=ALL-UNNAMED --add-opens=java.desktop/java.awt.dnd=ALL-UNNAMED --add-
:opens=java.desktop/java.awt.dndApeer=ALLfUNNAMED

--add-opens=java.desktop/java.awt.event=ALL-UNNAMED --add-opens=java.desktop/java.awt.font=ALL-UNNAMED --add-
éopens=java.desktop/java.awt‘geom=ALL—UNNAMED

‘-—add-opens=java.desktop/java.awt.im=ALL-UNNAMED --add-opens=java.desktop/java.awt.im.spi=ALL-UNNAMED --add-
éopens=java.desktop/java.awt.image=ALL—UNNAMED

‘--add-opens=java.desktop/java.awt.image.renderable=ALL-UNNAMED --add-opens=java.desktop/java.awt.peer=ALL-UNNAMED --add-
éopens=java.desktop/java.awt.print=ALL—UNNAMED

---add-opens=java.desktop/java.beans=ALL-UNNAMED --add-opens=java.desktop/java.beans.beancontext=ALL-UNNAMED --add-
éopens=java.desktop/javax.swing=ALL7UNNAMED

---add-opens=java.desktop/javax.swing.border=ALL-UNNAMED --add-opens=java.desktop/javax.swing.text=ALL-UNNAMED --add-
:pens=java.desktop/javax.swing‘text‘html=ALL—UNNAMED

:--add-opens=java.desktop/sun.awt=ALL-UNNAMED --add-opens=java.desktop/sun.font=ALL-UNNAMED --add-opens=java.desktop/sun.java2d=ALL-
‘UNNAMED

‘--add-opens=java.instrument/java.lang.instrument=ALL-UNNAMED --add-opens=java.logging/java.util.logging=ALL-UNNAMED --add-
éopens=java.manaqement/java.lang.management=ALL—UNNAMED

---add-opens=java.prefs/java.util.prefs=ALL-UNNAMED --add-opens=java.rmi/java.rmi=ALL-UNNAMED --add-opens=java.rmi/java.rmi.dgc=ALL-
‘UNNAMED :
‘--add-opens=java.rmi/java.rmi.registry=ALL-UNNAMED --add-opens=java.rmi/java.rmi.server=ALL-UNNAMED --add-opens=java.sql/java.sql=ALL-
‘UNNAMED :
‘--add-opens=java.xml/com.sun.org.apache.xerces.internal.dom=ALL-UNNAMED --add-
fopens:java.xml/com.sun.org.apache.xerces.internal.jaxp:ALL—UNNAMED
‘--add-opens=java.xml/com.sun.org.apache.xerces.internal.parsers=ALL-UNNAMED --add-
éopens=java.xml/com.sun.org.apacheAXerces.internal.util=ALL—UNNAMED

5. You must now change the parameters to the Polarion server based on your installation. You can check the

settings with the following screenshot:



& Debug Configurations O X

Create, manage, and run configurations

Create a configuration to launch an Eclipse application in debug mode.

O e B Xl Nl Name: Polarion Server

type filter text E] Main [po= .Algumenls| = Plug-ins| Configurati0n| Tracing | m En\.rironment| = Common| [P| Prototype
w & Eclipse Application Program arguments:
S New_configuration -os win32 -ws win32 -arch x86 -appld polarion.server a
@ Gradle Test

Java Applet

Java Application

Ju JUnit

Ji JUnit Plug-in Test v
Launch Grou

g 05Gi FramewF:Jrk Variable=

[Zl Remote Java Application

VM arguments:

-Kms236m -Xmx640m
-Deom.polarion.home=Ci\Palarion'pelarion
-¥¥:+UseBiasedlocking
-¥¥:BiasedLockingStartupDelay=0
--add-opens=java.base/java.io=ALL-UNNAMED
--add-opens=java.base/java.lang=ALL-UNNAMED

--add-nnenc—iava hacefiava lann annntatinn— Al | -1 IMMARAED
Variables...

B Use the -XX:+ShowCodeDetailsinExceptionMessages argument when launching

[ Use @argfile when launching

Working directory:

O Default: CHAWINDOWS\system32

() Other:

Workspace... File System... Variables...

. . Show Command Line Revert Apply
Filter matched 10 of 10 items

©

Figure EXEC-2: Debug - Arguments page
6. On the third "Plug-ins" tab, make sure, you have also selected "Target Platform" plugins.

7. Select all, and then click the Validate Plug-ins button. If there are some problems, uncheck the plugins
which are in conflict.



Mame: Polarion Server

= Main | 00-

Configurationl Tracing| - -3 Emrironment| i Common| [r] Prototype|

Launch with: Plug-ins selected below v Default Start level: Default Auto-Start: false
type filter text Select All
Plug-ins Start Level Auto-Start Deselect All
> @ *f Workspace
va eu Target Platform Select Working 5et..
BEI& antlr (2.7.7) default default Select Required
@ U= antlrd (4.5.3) default default
/] EIr: antlrd-runtime (4.3.3) default default Restore Defaults
°§In= bepkix (1.72.0) default default
-] A beprov (1.72.0) default default
-] = beutil (1.72.0) default default
B%Im checker-qual (3.12.0) default default
[-] e com.authljava-jwt (3.11.0) default default
B%Ik com.fasterxml.classmate (1.3.0) default default
ﬂ%br com.fasterxml jackson (2.13.4) default default
ﬂ%In: com.fasterxml jackson.annotations (2.14.2) default default
/] EIr: com.fastercml jackson.core (2.14.2) default default
°§In= com.fastercml jackson.databind (2.14.2) default default
M ¥ com fasteremliacksnn datafarmat v ml 17,1471 default refault D Only show selected
298 out of 302 selected

[JInclude required Plug-ins automatically while launching
B Include optional dependencies when computing required Plug-ins

B Add new workspace Plug-ins to this launch configuration automatically

B Validate Plug-ins automatically prior to launching Validate Plug-ins

Show Command Line Revert Apply

Figure EXEC-3: Debug - Plug-ins page
8. Other pages shouldn't be changed. Just click the Debug button, and go on with your new Polarion Server
application.



